TYPO3 PSR-2-Einrichtung in Ihrer bevorzugten PHP-IDE

Es ist immer eine gute Praxis, Ihren Code mit TYPO3 PSR-2 Standards von PHP zu schreiben, warum dann nicht einfach in Ihre bevorzugte PHP IDE integrieren? Um jeden Tag besseren Code zu schreiben!

1. PHP-Sturm

Step 1. Go to File -> Settings -> Code style -> PHP and navigate to that menu

Step 2. Choose option of PSR1/PSR2


2. Visual Studio Code

Step 1. Ctrl+P Search ext install kokororin.vscode-phpfmt

Step 2. Install the extensions

Explore at https://marketplace.visualstudio.com/items?itemName=kokororin.vscode-phpfmt


3. Sublime

Option 1. Installieren Sie PHPFMT

Step 1. Weiter zu Paketkontrolle (Ctrl + Shift + P)

Step 2. Suchen Sie "Paketkontrolle: Paket installieren"

Step 3. Installation von "phpfmt"

Step 4. Gehen Sie zu Präferenzen -> Paketeinstellungen -> phpfmt -> Einstellungen - Einstellungen Benutzer

{
    "version": 4,
    "php_bin":"/usr/bin/php",
    "psr1": true,
    "psr2": true,
    "format_on_save":false,
    "option": "value"
}

Option 2. Sublime Linter installieren

Step 1.Weiter zu Paketkontrolle (Ctrl + Shift + P)

Step 2. Suchen Sie "Paketkontrolle: Paket installieren"

Step 3. Installieren Sie folgende Pakete

SublimeLinter
SublimeLinter-php
SublimeLinter-phpcs

Step 4. Gehen Sie zu Voreinstellungen -> Paketeinstellungen -> SublimeLinter -> Einstellungen

{
    "delay": 0.5,
    "linters": {
        "php": {
            "@disable": false,
            "args": [],
            "excludes": []
        },
        "phpcs": {
            "@disable": false,
            "args": [
                "-n"
            ],
            "excludes": [
                "*.phtml",
                "*.twig"
            ],
            "standard": "PSR2"
        }
    }
}

Post a Comment

×
Captcha Code Kann das Bild nicht gelesen werden? Klicken Sie hier, um zu aktualisieren

Got answer to the question you were looking for?